ネットワーク

Cisco IOSのBGP基本設定

投稿者情報

  • 運営局 投稿
  • 投稿日

コンテンツ情報

本文内容

 Cisco IOSを利用してBGPの基本的な設定例を紹介

s5msR1k.png

 

設定環境

 

今回設定したルータは下記のIOS Verを利用して実施しました。
Cisco IOS XE Software, Version 16.11.01b

 

設定構成図

 

RI42JSt.png

 

  • iBGPはloopbackupインターフェイス間で接続
  • eBGPはR12側はGi2,R20側はGi1にて接続
  • AS10内はOSPFにて全てのインターフェイス間で通信が可能
  • AS10の経路広報はR12にて10.10.0.0/8(static null0)をnetworkコマンドで実施
  • AS20の経路広報はR20にて20.0.0.0/8(static null0)をnetworkコマンドで実施

BGPの基本設定

R12のBGP設定コマンドは下記になります。

 

router bgp 10
 bgp router-id 10.0.0.12
 no bgp default ipv4-unicast
 neighbor 10.0.0.11 remote-as 10
 neighbor 10.0.0.11 update-source Loopback0
 neighbor 10.12.20.20 remote-as 20
 !
 address-family ipv4
  network 10.0.0.0
  neighbor 10.0.0.11 activate
  neighbor 10.12.20.20 activate
 exit-address-family
exit

 

BGPプロトコルの有効化

(config)#router bgp AS_NUMBER

 

コマンド引数 説明
AS_NUMBER 自身のルータのAS番号を設定します。AS番号についてはBGPとはのページに記載

BGP ルータID の設定

(config-router)# bgp router-id BGP_ROUTER_ID
コマンド引数 説明
BGP_ROUTER_ID BGPルータIDはIPv4アドレス同様の32bitのフォールドになります。形式的にIPv4アドレスと同じく、AAA.BBB.CCC.DDDと入力します。
BGPのパス選択で利用されます。一般的には固定でかつユーニークにな値を入れます。今回の設定はloopbackインターフェイスのIPアドレスと同じ値を設定しています。
※オプションでinterface を指定することも可能です。

BGP デフォルト ipv4 unicast の無効化

	
(config-router)# no bgp default ipv4-unicast

CiscoIOSのBGPはdefaultでIPv4 unicastが有効化となっています。この設定を入れることで個別にaddress familyを有効化する形にします。

このサイトではIPv4 unicat を個別のaddress-familyの形式で設定します。

BGPピアの設定

config-router)# neighbor PEER_ADDRESS remote-as PEER_AS_NUMBER
コマンド引数 説明
PEER_ADDRESS 接続先のIPアドレスを設定します。
PEER_AS_NUMBER 接続先BGPピアのAS番号を設定します。AS番号についてはBGPとはのページを参照

BGPルータ間のneighbor設定方法になります。iBGP,eBGPの違いはAS番号が自身と同一の場合iBGP、異なる場合はeBGPとなります。

BGPのピアの送信元アドレスの指定(オプション)

(config-router)# neighbor PEER_ADDRESS update-source INTERFACE
コマンド引数 説明
PEER_ADDRESS 接続先のIPアドレスを設定します。
INTERFACE BGPピアのソース(接続元)のインターフェイスを指定します。

設定はオプションになります。設定を行わなければ、BGPパケットを送信するインターフェイスになります。
今回はeBGP側は設定していませんので、eBGP側はパケットを送信するGigabitEthernet1が送信元アドレスになります。

BGP経路のアドバタイズ設定

(config-router-af)# network IP_ADDRESS mask NETMASK
コマンド引数 説明
IP_ADDRESS 広報する経路のIPアドレスを設定します。
NET_MASK 広報する経路のネットマスクを設定します。

NETWORKコマンドによるBGP経路の広報設定にはルーティングテーブルに該当の経路が登録されている必要があります。

今回はBGPで広報するアドレスをstatic(next-hop null0)にて下記の設定してルーティングテーブルに登録しています。

 

R12(config)#ip route 10.0.0.0 255.0.0.0 null 0

上記設定で10.0.0.0/8がルーティングテーブルに登録されます。

 

R12#show ip route static 
      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
S        10.0.0.0/8 is directly connected, Null0
R12#

 

今回はアドバタイズ設定方法としてnetworkコマンドを紹介しましたが、ルータ集約のaggreaget-addressコマンド、IGPからBGPへの再配布による方法もあります。

BGPピアのアドレスファミリー IPv4 Unicastの有効化

 

(config-router-af)# neighbor PEER_ADDRESS activate

 

 

コマンド引数 説明
PEER_ADDRESS 接続先のIPアドレスを設定します。

接続先のBGPピアとIPv4 Unicastの経路交換を有効化する設定です。

 

関連資料

ネットワーク

新着投稿


  • 投稿がありません。

新着書込み


  • 書込みがありません。
アラート 0